Zyxel USG / VPN < 5.37 Privilege Management

medium Nessus Plugin ID 186482


The remote security gateway is affected by a privilege management vulnerability.


Firmware version of the Zyxel USG or VPN device is less than 5.37. This means the Zyxel device is vulnerable to the following privilege management vulnerability:

- An improper privilege management vulnerability in the hotspot feature could allow an authenticated local attacker to access the system files on an affected device. (CVE-2023-5960)

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.


Upgrade to Zyxel USG / ATP / VPN to 5.37 or later.

See Also


Plugin Details

Severity: Medium

ID: 186482

File Name: zyxel_usg_CVE-2023-5960.nasl

Version: 1.2

Type: combined

Family: Firewalls

Published: 11/30/2023

Updated: 12/4/2023

Supported Sensors: Nessus

Risk Information


Risk Factor: Low

Score: 3.6


Risk Factor: Medium

Base Score: 4.6

Temporal Score: 3.4

Vector: CVSS2#AV:L/AC:L/Au:S/C:C/I:N/A:N

CVSS Score Source: CVE-2023-5960


Risk Factor: Medium

Base Score: 5.5

Temporal Score: 4.8

Vector: CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/h:zyxel:usg_flex

Required KB Items: installed_sw/Zyxel Unified Security Gateway (USG)

Exploit Ease: No known exploits are available

Patch Publication Date: 11/28/2023

Vulnerability Publication Date: 11/28/2023

Reference Information

CVE: CVE-2023-5960

IAVA: 2023-A-0655