Zyxel USG / ATP < 5.37 Buffer Overflow

medium Nessus Plugin ID 186481


The remote security gateway is affected by a buffer overflow vulnerability.


Firmware version of the Zyxel USG or ATP device is less than 5.37. This means the Zyxel device is vulnerable to the following buffer overflow vulnerability:

- A buffer overflow vulnerability could allow an authenticated local attacker with administrator privileges to cause denial-of-service (DoS) conditions by executing the CLI command with crafted strings on an affected device.

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.


Upgrade to Zyxel USG / ATP / VPN to 5.37 or later.

See Also


Plugin Details

Severity: Medium

ID: 186481

File Name: zyxel_usg_CVE-2023-4397.nasl

Version: 1.2

Type: combined

Family: Firewalls

Published: 11/30/2023

Updated: 12/4/2023

Supported Sensors: Nessus

Risk Information


Risk Factor: Low

Score: 3.6


Risk Factor: Medium

Base Score: 4.3

Temporal Score: 3.2

Vector: CVSS2#AV:L/AC:L/Au:M/C:N/I:N/A:C

CVSS Score Source: CVE-2023-4397


Risk Factor: Medium

Base Score: 4.4

Temporal Score: 3.9

Vector: CVSS:3.0/AV:L/AC:L/PR:H/UI:N/S:U/C:N/I:N/A:H

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/h:zyxel:usg_flex

Required KB Items: installed_sw/Zyxel Unified Security Gateway (USG)

Exploit Ease: No known exploits are available

Patch Publication Date: 11/28/2023

Vulnerability Publication Date: 11/28/2023

Reference Information

CVE: CVE-2023-4397

IAVA: 2023-A-0655