GlobalSCAPE Secure FTP Server User Input Overflow

Critical Nessus Plugin ID 18627


The remote FTP server is affected by a buffer overflow vulnerability.


The remote host is running GlobalSCAPE Secure FTP Server.

GlobalSCAPE Secure FTP Server 3.0.2 and prior versions are affected by a buffer overflow due to mishandling the user-supplied input.

An attacker would first need to authenticate to the server before they can execute arbitrary commands.


Upgrade to GlobalSCAPE Secure FTP 3.0.3 Build 4.29.2005 or later as this reportedly fixes the issue.

See Also

Plugin Details

Severity: Critical

ID: 18627

File Name: globalscapeftp_user_input.nasl

Version: $Revision: 1.19 $

Type: remote

Family: FTP

Published: 2005/07/06

Modified: 2016/10/10

Dependencies: 10092

Risk Information

Risk Factor: Critical


Base Score: 10

Temporal Score: 8.3

Vector: CVSS2#AV:N/AC:L/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:F/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:globalscape:secure_ftp_server

Exploit Available: true

Exploit Ease: Exploits are available

Vulnerability Publication Date: 2005/05/01

Exploitable With

Core Impact

Metasploit (GlobalSCAPE Secure FTP Server Input Overflow)

Reference Information

CVE: CVE-2005-1415

BID: 13454

OSVDB: 16049