Slackware Linux 15.0 / current mozilla-firefox Multiple Vulnerabilities (SSA:2023-297-01)

critical Nessus Plugin ID 183835

Synopsis

The remote Slackware Linux host is missing a security update to mozilla-firefox.

Description

The version of mozilla-firefox installed on the remote host is prior to 115.4.0esr. It is, therefore, affected by multiple vulnerabilities as referenced in the SSA:2023-297-01 advisory.

- It was possible for certain browser prompts and dialogs to be activated or dismissed unintentionally by the user due to an insufficient activation-delay. (CVE-2023-5721)

- Drivers are not always robust to extremely large draw calls and in some cases this scenario could have led to a crash. (CVE-2023-5724)

- A malicious installed WebExtension could open arbitrary URLs, which under the right circumstance could be leveraged to collect sensitive user data. (CVE-2023-5725)

- A website could have obscured the full screen notification by using the file open dialog. This could have led to user confusion and possible spoofing attacks. Note: This issue only affected macOS operating systems. Other operating systems are unaffected. (CVE-2023-5726)

- The executable file warning was not presented when downloading .msix, .msixbundle, .appx, and .appxbundle files, which can run commands on a user's computer. Note: This issue only affected Windows operating systems. Other operating systems are unaffected. (CVE-2023-5727)

- During garbage collection extra operations were performed on a object that should not be. This could have led to a potentially exploitable crash. (CVE-2023-5728)

- Memory safety bugs present in Firefox 118, Firefox ESR 115.3, and Thunderbird 115.3. Some of these bugs showed evidence of memory corruption and we presume that with enough effort some of these could have been exploited to run arbitrary code. (CVE-2023-5730)

- An attacker could have created a malicious link using bidirectional characters to spoof the location in the address bar when visited. (CVE-2023-5732)

Note that Nessus has not tested for these issues but has instead relied only on the application's self-reported version number.

Solution

Upgrade the affected mozilla-firefox package.

See Also

http://www.nessus.org/u?7d5b75de

Plugin Details

Severity: Critical

ID: 183835

File Name: Slackware_SSA_2023-297-01.nasl

Version: 1.3

Type: local

Published: 10/24/2023

Updated: 12/1/2023

Supported Sensors: Nessus

Risk Information

VPR

Risk Factor: Medium

Score: 6.7

CVSS v2

Risk Factor: Critical

Base Score: 10

Temporal Score: 7.4

Vector: CVSS2#AV:N/AC:L/Au:N/C:C/I:C/A:C

CVSS Score Source: CVE-2023-5730

CVSS v3

Risk Factor: Critical

Base Score: 9.8

Temporal Score: 8.5

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/o:slackware:slackware_linux:15.0, cpe:/o:slackware:slackware_linux, p-cpe:/a:slackware:slackware_linux:mozilla-firefox

Required KB Items: Host/Slackware/release, Host/Slackware/packages, Host/local_checks_enabled

Exploit Ease: No known exploits are available

Patch Publication Date: 10/24/2023

Vulnerability Publication Date: 10/24/2023

Reference Information

CVE: CVE-2023-5721, CVE-2023-5724, CVE-2023-5725, CVE-2023-5726, CVE-2023-5727, CVE-2023-5728, CVE-2023-5730, CVE-2023-5732

IAVA: 2023-A-0585-S