Slackware Linux 15.0 / current netatalk Vulnerability (SSA:2023-279-01)

critical Nessus Plugin ID 182740

Synopsis

The remote Slackware Linux host is missing a security update to netatalk.

Description

The version of netatalk installed on the remote host is prior to 3.1.18. It is, therefore, affected by a vulnerability as referenced in the SSA:2023-279-01 advisory.

- The combination of primitives offered by SMB and AFP in their default configuration allows the arbitrary writing of files. By exploiting these combination of primitives, an attacker can execute arbitrary code.
(CVE-2022-22995)

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.

Solution

Upgrade the affected netatalk package.

See Also

http://www.nessus.org/u?83bba9ca

Plugin Details

Severity: Critical

ID: 182740

File Name: Slackware_SSA_2023-279-01.nasl

Version: 1.0

Type: local

Published: 10/6/2023

Updated: 10/6/2023

Supported Sensors: Nessus

Risk Information

VPR

Risk Factor: High

Score: 7.4

CVSS v2

Risk Factor: High

Base Score: 7.5

Temporal Score: 5.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

CVSS Score Source: CVE-2022-22995

CVSS v3

Risk Factor: Critical

Base Score: 9.8

Temporal Score: 8.5

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

CPE: p-cpe:/a:slackware:slackware_linux:netatalk, cpe:/o:slackware:slackware_linux, cpe:/o:slackware:slackware_linux:15.0

Required KB Items: Host/local_checks_enabled, Host/Slackware/release, Host/Slackware/packages

Exploit Ease: No known exploits are available

Patch Publication Date: 10/6/2023

Vulnerability Publication Date: 3/25/2022

Reference Information

CVE: CVE-2022-22995