Slackware Linux 15.0 / current libvpx Vulnerability (SSA:2023-273-01)

high Nessus Plugin ID 182406

Synopsis

The remote Slackware Linux host is missing a security update to libvpx.

Description

The version of libvpx installed on the remote host is prior to 1.12.0 / 1.13.1. It is, therefore, affected by a vulnerability as referenced in the SSA:2023-273-01 advisory.

- Heap buffer overflow in vp8 encoding in libvpx in Google Chrome prior to 117.0.5938.132 and libvpx 1.13.1 allowed a remote attacker to potentially exploit heap corruption via a crafted HTML page. (Chromium security severity: High) (CVE-2023-5217)

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.

Solution

Upgrade the affected libvpx package.

See Also

http://www.nessus.org/u?77fd2e0d

Plugin Details

Severity: High

ID: 182406

File Name: Slackware_SSA_2023-273-01.nasl

Version: 1.2

Type: local

Published: 9/30/2023

Updated: 10/2/2023

Supported Sensors: Nessus

Risk Information

VPR

Risk Factor: Critical

Score: 9.2

CVSS v2

Risk Factor: Critical

Base Score: 10

Temporal Score: 8.3

Vector: CVSS2#AV:N/AC:L/Au:N/C:C/I:C/A:C

CVSS Score Source: CVE-2023-5217

CVSS v3

Risk Factor: High

Base Score: 8.8

Temporal Score: 8.2

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

Temporal Vector: CVSS:3.0/E:F/RL:O/RC:C

Vulnerability Information

CPE: p-cpe:/a:slackware:slackware_linux:libvpx, cpe:/o:slackware:slackware_linux, cpe:/o:slackware:slackware_linux:15.0

Required KB Items: Host/local_checks_enabled, Host/Slackware/release, Host/Slackware/packages

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 9/30/2023

Vulnerability Publication Date: 9/27/2023

CISA Known Exploited Vulnerability Due Dates: 10/23/2023

Reference Information

CVE: CVE-2023-5217