Slackware Linux 14.2 / 15.0 / current cups Vulnerability (SSA:2023-264-02)

high Nessus Plugin ID 181770


The remote Slackware Linux host is missing a security update to cups.


The version of cups installed on the remote host is prior to 2.1.4 / 2.4.7. It is, therefore, affected by a vulnerability as referenced in the SSA:2023-264-02 advisory.

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.


Upgrade the affected cups package.

See Also

Plugin Details

Severity: High

ID: 181770

File Name: Slackware_SSA_2023-264-02.nasl

Version: 1.3

Type: local

Published: 9/21/2023

Updated: 11/10/2023

Risk Information


Risk Factor: Medium

Score: 6.7


Risk Factor: Medium

Base Score: 6.2

Temporal Score: 4.9

Vector: CVSS2#AV:L/AC:H/Au:N/C:C/I:C/A:C

CVSS Score Source: CVE-2023-4504


Risk Factor: High

Base Score: 7

Temporal Score: 6.3

Vector: CVSS:3.0/AV:L/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:H

Temporal Vector: CVSS:3.0/E:P/RL:O/RC:C

Vulnerability Information

CPE: p-cpe:/a:slackware:slackware_linux:cups, cpe:/o:slackware:slackware_linux, cpe:/o:slackware:slackware_linux:14.2, cpe:/o:slackware:slackware_linux:15.0

Required KB Items: Host/local_checks_enabled, Host/Slackware/release, Host/Slackware/packages

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 9/21/2023

Vulnerability Publication Date: 9/21/2023

Reference Information

CVE: CVE-2023-4504