Slackware Linux 14.1 / 14.2 / 15.0 / current libarchive Vulnerability (SSA:2023-256-02)

high Nessus Plugin ID 181394


The remote Slackware Linux host is missing a security update to libarchive.


The version of libarchive installed on the remote host is prior to 3.7.2. It is, therefore, affected by a vulnerability as referenced in the SSA:2023-256-02 advisory.

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.


Upgrade the affected libarchive package.

See Also

Plugin Details

Severity: High

ID: 181394

File Name: Slackware_SSA_2023-256-02.nasl

Version: 1.0

Type: local

Published: 9/14/2023

Updated: 9/14/2023

Supported Sensors: Nessus

Vulnerability Information

CPE: p-cpe:/a:slackware:slackware_linux:libarchive, cpe:/o:slackware:slackware_linux, cpe:/o:slackware:slackware_linux:14.1, cpe:/o:slackware:slackware_linux:14.2, cpe:/o:slackware:slackware_linux:15.0

Required KB Items: Host/local_checks_enabled, Host/Slackware/release, Host/Slackware/packages

Exploit Ease: No known exploits are available

Patch Publication Date: 9/13/2023

Vulnerability Publication Date: 9/13/2023