SUSE-SA:2005:021: kernel

High Nessus Plugin ID 17982


The remote host is missing a vendor-supplied security patch


The remote host is missing the patch for the advisory SUSE-SA:2005:021 (kernel).

This Linux kernel security update fixes a problem within the Bluetooth kernel stack which can be used by a local attacker to gain root access or crash the machine.

To exploit this problem, the Bluetooth modules do not need to be loaded since they are auto loaded on demand (except in products mentioned below).

This problem has been assigned the Mitre CVE ID CVE-2005-0750.

Updated packages have been provided for the default affected products:
- SUSE Linux 8.2, 9.0 and 9.2 (both i386 and x86_64) - SUSE Linux Enterprise Server 8 (i386, ia64 and x86_64) - SUSE Linux Desktop 1.0

Other architectures do not have Bluetooth enabled.
Also SUSE Linux 9.1, SUSE Linux Enterprise Server 9 and Novell Linux Desktop 9 are not affected by default since the Bluetooth module is not auto loaded. These will get the patch with the next security update.


Plugin Details

Severity: High

ID: 17982

File Name: suse_SA_2005_021.nasl

Version: $Revision: 1.9 $

Agent: unix

Published: 2005/04/06

Modified: 2016/12/29

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 7.2

Vector: CVSS2#AV:L/AC:L/Au:N/C:C/I:C/A:C

Vulnerability Information

Required KB Items: Host/SuSE/rpm-list

Reference Information

CVE: CVE-2005-0750