MySQL < 3.23.50 / 4.0.24 / 4.1.6 / 5.0.3 Insecure Temporary File Creation

medium Nessus Plugin ID 17838
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

Arbitrary files could be read or overwritten via the remote database server.

Description

The version of MySQL installed on the remote host is older than 3.23.50, 4.0.24, 4.1.6 or 5.0.3. As such, the mysqlaccess script included with it reportedly could be used to read or overwrite arbitrary files via a symlink attack.

Solution

Upgrade to MySQL version 3.23.50 / 4.0.24 / 4.1.6 / 5.0.3 or later.

See Also

http://lists.mysql.com/internals/20600

https://lists.mysql.com/announce/269

Plugin Details

Severity: Medium

ID: 17838

File Name: mysql_client_symlink_attack.nasl

Version: 1.5

Type: remote

Family: Databases

Published: 1/18/2012

Updated: 11/15/2018

Dependencies: mysql_version.nasl, mysql_login.nasl

Configuration: Enable paranoid mode

Risk Information

VPR

Risk Factor: Medium

Score: 5.2

CVSS v2

Risk Factor: Medium

Base Score: 4.6

Temporal Score: 3.4

Vector: AV:L/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: E:U/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:mysql:mysql

Required KB Items: Settings/ParanoidReport

Exploit Ease: No known exploits are available

Vulnerability Publication Date: 1/17/2005

Reference Information

CVE: CVE-2005-0004

BID: 12277