MySQL < 6.0.9-alpha / 5.5.3 Access Control Weakness

Medium Nessus Plugin ID 17837

Synopsis

Access restrictions can be bypassed on the remote database server.

Description

The version of MySQL installed on the remote host is older than 6.0.9-alpha / 5.5.3. As such, it reportedly allows a remote attacker to bypass access restrictions when the data directory contains a symbolic link to a different file system.

Solution

Upgrade to MySQL version 6.0.9-alpha / 5.5.3 or later.

See Also

https://marc.info/?l=oss-security&m=125908040022018&w

https://lists.mysql.com/commits/59711

https://bugs.mysql.com/bug.php?id=39277

Plugin Details

Severity: Medium

ID: 17837

File Name: mysql_6_0_9.nasl

Version: 1.7

Type: remote

Family: Databases

Published: 2012/01/18

Updated: 2018/11/15

Dependencies: 91823, 10719

Configuration: Enable paranoid mode

Risk Information

Risk Factor: Medium

CVSS v2.0

Base Score: 6

Temporal Score: 4.4

Vector: CVSS2#AV:N/AC:M/Au:S/C:P/I:P/A:P

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:mysql:mysql

Required KB Items: Settings/ParanoidReport

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2008/12/08

Vulnerability Publication Date: 2008/11/24

Reference Information

CVE: CVE-2008-7247

BID: 38043

CWE: 59