MySQL < 5.5.6 Multiple Denial of Service

medium Nessus Plugin ID 17836
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

The remote database server is vulnerable to multiple denial of service attacks.

Description

The version of MySQL installed on the remote host is older than 5.5.6. As such, it reportedly is prone to multiple denial of service attacks :

- The improper handling of type errors during argument evaluation in extreme-value functions, e.g., 'LEAST()' or 'GREATEST()' causes server crashes. (CVE-2010-3833)

- Remote authenticated attackers could crash the server.
(CVE-2010-3834 & CVE-2010-3836)

- The use of 'GROUP_CONCAT()' and 'WITH ROLLUP' caused server crashes. (CVE-2010-3837)

- The use of an intermediate temporary table and queries containing calls to 'GREATEST()' or 'LEAST()', having a list of both numeric and 'LONGBLOB' arguments, caused server crashes. (CVE-2010-3838)

- The use of nested joins in prepared statements or stored procedures could result in infinite loops. (CVE-2010-3839)

Solution

Upgrade to MySQL version 5.5.6 or later.

See Also

https://bugzilla.redhat.com/show_bug.cgi?id=640751

https://bugs.mysql.com/bug.php?id=55826

https://bugs.mysql.com/bug.php?id=54476

https://bugs.mysql.com/bug.php?id=54461

https://bugs.mysql.com/bug.php?id=53544

https://dev.mysql.com/doc/relnotes/mysql/5.5/en/news-5-5-6.html

Plugin Details

Severity: Medium

ID: 17836

File Name: mysql_5_5_6.nasl

Version: 1.7

Type: remote

Family: Databases

Published: 1/18/2012

Updated: 11/15/2018

Dependencies: mysql_version.nasl, mysql_login.nasl

Configuration: Enable paranoid mode

Risk Information

VPR

Risk Factor: Low

Score: 3.6

CVSS v2

Risk Factor: Medium

Base Score: 5

Temporal Score: 3.7

Vector: AV:N/AC:L/Au:N/C:N/I:N/A:P

Temporal Vector: E:U/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:mysql:mysql

Required KB Items: Settings/ParanoidReport

Exploit Ease: No known exploits are available

Vulnerability Publication Date: 9/10/2010

Reference Information

CVE: CVE-2010-3833, CVE-2010-3834, CVE-2010-3835, CVE-2010-3836, CVE-2010-3837, CVE-2010-3838, CVE-2010-3839

BID: 43676