MySQL < 5.0.92 Multiple Denial of Service

Medium Nessus Plugin ID 17834

Synopsis

The remote database server is vulnerable to multiple denial of service attacks.

Description

The version of MySQL installed on the remote host is older than 5.0.92. As such, it reportedly is prone to multiple denial of service attacks :

- The improper handling of type errors during argument evaluation in extreme-value functions, e.g., 'LEAST()' or 'GREATEST()' causes server crashes. (CVE-2010-3833)

- Remote authenticated attackers could crash the server.
(CVE-2010-3834 & CVE-2010-3836)

- The use of 'GROUP_CONCAT()' and 'WITH ROLLUP' caused server crashes. (CVE-2010-3837)

- The use of an intermediate temporary table and queries containing calls to 'GREATEST()' or 'LEAST()', having a list of both numeric and 'LONGBLOB' arguments, caused server crashes. (CVE-2010-3838)

Solution

Upgrade to MySQL version 5.0.92 or later.

See Also

https://bugs.mysql.com/bug.php?id=55826

https://bugs.mysql.com/bug.php?id=54476

https://bugs.mysql.com/bug.php?id=54461

http://dev.mysql.com/doc/refman/5.0/en/news-5-0-92.html

https://bugzilla.redhat.com/show_bug.cgi?id=640751

Plugin Details

Severity: Medium

ID: 17834

File Name: mysql_5_0_92.nasl

Version: 1.7

Type: remote

Family: Databases

Published: 2012/01/18

Updated: 2018/11/15

Dependencies: 10719, 91823

Configuration: Enable paranoid mode

Risk Information

Risk Factor: Medium

CVSS v2.0

Base Score: 5

Temporal Score: 3.7

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:P

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:mysql:mysql

Required KB Items: Settings/ParanoidReport

Exploit Available: false

Exploit Ease: No known exploits are available

Vulnerability Publication Date: 2010/09/10

Reference Information

CVE: CVE-2010-3833, CVE-2010-3834, CVE-2010-3836, CVE-2010-3837, CVE-2010-3838

BID: 43676