MySQL < 4.1.23 / 5.0.42 Access Control Vulnerability

medium Nessus Plugin ID 17829
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

The remote database server is affected by an access control vulnerability.

Description

The version of MySQL installed on the remote host is older than 4.1.23 or 5.0.42. As such, it reportedly allows a remote, authenticated user without the DROP privilege to rename arbitrary tables.

Solution

Upgrade to MySQL version 4.1.23 / 5.0.42 or later.

See Also

http://bugs.mysql.com/bug.php?id=27515

Plugin Details

Severity: Medium

ID: 17829

File Name: mysql_4_1_23_5_0_42.nasl

Version: 1.5

Type: remote

Family: Databases

Published: 1/18/2012

Updated: 7/16/2018

Dependencies: mysql_version.nasl, mysql_login.nasl

Configuration: Enable paranoid mode

Risk Information

VPR

Risk Factor: Medium

Score: 4

CVSS v2

Risk Factor: Medium

Base Score: 4.9

Temporal Score: 3.6

Vector: AV:N/AC:M/Au:S/C:N/I:P/A:P

Temporal Vector: E:U/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:mysql:mysql

Required KB Items: Settings/ParanoidReport

Exploit Ease: No known exploits are available

Vulnerability Publication Date: 5/8/2007

Reference Information

CVE: CVE-2007-2691

BID: 24016