MySQL < 4.1.13a / 5.0.10 Zlib Library Buffer Overflow

High Nessus Plugin ID 17827


Arbitrary code could be executed on the remote database server.


The version of MySQL installed on the remote host is older than 4.1.13a or 5.0.10 and as such, may have been linked with zlib 1.2.2.

On operating systems where the MySQL binaries are statically linked (mainly Windows and HP-UX), a remote attacker could crash the server or execute arbitrary code by triggering a buffer overflow in zlib.


Upgrade to MySQL version 4.1.13a / 5.0.10 or later.

See Also

Plugin Details

Severity: High

ID: 17827

File Name: mysql_4_1_13a_or_5_0_10.nasl

Version: 1.6

Type: remote

Family: Databases

Published: 2012/01/18

Updated: 2018/07/16

Dependencies: 10719, 91823

Configuration: Enable paranoid mode

Risk Information

Risk Factor: High

CVSS v2.0

Base Score: 7.5

Temporal Score: 5.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:mysql:mysql

Required KB Items: Settings/ParanoidReport

Exploit Available: false

Exploit Ease: No known exploits are available

Vulnerability Publication Date: 2005/07/07

Reference Information

CVE: CVE-2005-2096

BID: 14162

CERT: 680620