MySQL < 4.1.13 / 5.0.8 DOS Device Name Denial of Service Vulnerabilities

medium Nessus Plugin ID 17826
New! Vulnerability Priority Rating (VPR)

Tenable calculates a dynamic VPR for every vulnerability. VPR combines vulnerability information with threat intelligence and machine learning algorithms to predict which vulnerabilities are most likely to be exploited in attacks. Read more about what VPR is and how it is different from CVSS.

VPR Score: 3.6

Synopsis

The remote database server may be affected by denial of service vulnerabilities.

Description

The version of MySQL installed on the remote host is older than 4.1.13 or 5.0.8.

On Windows, a remote attacker can crash the server via a 'use' command followed by MS-DOS device name, e.g. LPT1.

Solution

Upgrade to MySQL version 4.1.13 / 5.0.8 or later.

See Also

http://marc.info/?l=bugtraq&m=111091250923281&w=2

https://bugs.mysql.com/bug.php?id=9148

https://lists.mysql.com/internals/25190

https://lists.mysql.com/internals/24584

https://seclists.org/bugtraq/2005/Mar/270

Plugin Details

Severity: Medium

ID: 17826

File Name: mysql_4_1_13_or_5_0_8.nasl

Version: 1.6

Type: remote

Family: Databases

Published: 1/18/2012

Updated: 11/15/2018

Dependencies: 10719, 91823

Configuration: Enable paranoid mode

Risk Information

Risk Factor: Medium

VPR Score: 3.6

CVSS v2.0

Base Score: 5

Temporal Score: 3.7

Vector: AV:N/AC:L/Au:N/C:N/I:N/A:P

Temporal Vector: E:U/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:mysql:mysql

Required KB Items: Settings/ParanoidReport

Exploit Available: false

Exploit Ease: No known exploits are available

Vulnerability Publication Date: 3/12/2005

Reference Information

CVE: CVE-2005-0799