yaSSL 1.7.5 Buffer Overflow

high Nessus Plugin ID 17814

Synopsis

Arbitrary code can be executed on the remote database server.

Description

The version of MySQL installed on the remote host reportedly allows a remote user to execute arbitrary code by exploiting a buffer overflow in yaSSL 1.7.5 or earlier.

Solution

Upgrade to MySQL version 5.0.54a, 5.1.23, 6.0.4 or later.

See Also

https://bugs.mysql.com/bug.php?id=33814

https://www.securityfocus.com/archive/1/archive/1/485810/100/0/threaded

Plugin Details

Severity: High

ID: 17814

File Name: mysql_6_0_4_yaSSL.nasl

Version: 1.7

Type: remote

Family: Databases

Published: 1/16/2012

Updated: 11/15/2018

Configuration: Enable paranoid mode

Risk Information

VPR

Risk Factor: High

Score: 7.3

CVSS v2

Risk Factor: High

Base Score: 7.5

Temporal Score: 6.2

Vector: AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: E:F/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:mysql:mysql

Required KB Items: Settings/ParanoidReport

Exploit Available: true

Exploit Ease: Exploits are available

Vulnerability Publication Date: 1/22/2008

Exploitable With

Core Impact

Metasploit (MySQL yaSSL SSL Hello Message Buffer Overflow)

Reference Information

CVE: CVE-2008-0226, CVE-2008-0227

BID: 27140

CWE: 119