MySQL < 5.0.89 / 5.1.42 / 5.4.2 / 5.5.1 / 6.0.14 Client XSS

Low Nessus Plugin ID 17811

New! Vulnerability Priority Rating (VPR)

Tenable calculates a dynamic VPR for every vulnerability. VPR combines vulnerability information with threat intelligence and machine learning algorithms to predict which vulnerabilities are most likely to be exploited in attacks. Read more about what VPR is and how it's different from CVSS.

VPR Score: 3.8

Synopsis

A remote database client have a cross-site scripting vulnerability.

Description

The version of MySQL installed on the remote host is earlier than 5.0.89 / 5.1.42 / 5.4.2 / 5.5.1 / 6.0.14 and thus does not properly encode angle brackets when 'mysql --html' option is used. Depending on how the output of the mysql client command is processed, the user may be vulnerable to cross-site scripting attacks.

Solution

Upgrade to MySQL version 5.0.89 / 5.1.42 / 5.4.2 / 5.5.1 / 6.0.14 or later.

See Also

https://bugs.mysql.com/bug.php?id=27884

Plugin Details

Severity: Low

ID: 17811

File Name: mysql_6_0_14_XSS.nasl

Version: 1.6

Type: remote

Family: Databases

Published: 2012/01/16

Updated: 2018/11/15

Dependencies: 10719, 91823

Configuration: Enable paranoid mode

Risk Information

Risk Factor: Low

VPR Score: 3.8

CVSS v2.0

Base Score: 2.6

Temporal Score: 2

Vector: CVSS2#AV:N/AC:H/Au:N/C:N/I:P/A:N

Temporal Vector: CVSS2#E:POC/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:mysql:mysql

Required KB Items: Settings/ParanoidReport

Exploit Available: true

Exploit Ease: Exploits are available

Vulnerability Publication Date: 2008/09/30

Reference Information

CVE: CVE-2008-4456

BID: 31486

CWE: 79