MySQL < 4.1.21 / 5.0.24 Privilege Persistence

Low Nessus Plugin ID 17802

Synopsis

The remote database server allows a local user to access unauthorized data.

Description

The version of MySQL installed on the remote host is earlier than 4.1.21 / 5.0.24 and thus reportedly allows a local user to access a table after his privileges on it were revoked.

Solution

Upgrade to MySQL version 5.0.24 or later.

See Also

http://dev.mysql.com/doc/refman/4.1/en/news-4-1-21.html

http://dev.mysql.com/doc/refman/5.0/en/news-5-0-24.html

Plugin Details

Severity: Low

ID: 17802

File Name: mysql_5_0_24.nasl

Version: 1.5

Type: remote

Family: Databases

Published: 2012/01/16

Updated: 2018/07/16

Dependencies: 10719, 91823

Configuration: Enable paranoid mode

Risk Information

Risk Factor: Low

CVSS v2.0

Base Score: 2.1

Temporal Score: 1.6

Vector: CVSS2#AV:L/AC:L/Au:N/C:P/I:N/A:N

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:mysql:mysql

Required KB Items: Settings/ParanoidReport

Exploit Available: false

Exploit Ease: No known exploits are available

Vulnerability Publication Date: 2006/08/01

Reference Information

CVE: CVE-2006-4031

BID: 19279