OpenSSL < 0.9.8f Multiple Vulnerabilities

High Nessus Plugin ID 17760


The remote server is affected by multiple vulnerabilities.


According to its banner, the remote server is running a version of OpenSSL that is earlier than 0.9.8f. As such, it is affected by the following vulnerabilities :

- A local attacker could perform a side-channel attack against the Montgomery multiplication code and retrieve RSA private keys. Note that this has not been exploited outside a laboratory environment. (CVE-2007-3108)

- A remote attacker could execute arbitrary code by exploiting an off-by-one error in the DTLS implementation. (CVE-2007-4995)


Upgrade to OpenSSL 0.9.8f or later.

See Also

Plugin Details

Severity: High

ID: 17760

File Name: openssl_0_9_8f.nasl

Version: $Revision: 1.9 $

Type: remote

Family: Web Servers

Published: 2012/01/04

Modified: 2017/06/12

Dependencies: 57323

Risk Information

Risk Factor: High


Base Score: 9.3

Temporal Score: 6.9

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:openssl:openssl

Required KB Items: openssl/port

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2007/10/11

Vulnerability Publication Date: 2007/08/13

Reference Information

CVE: CVE-2007-3108, CVE-2007-4995

BID: 25163, 26055

OSVDB: 37055, 37895

CERT: 724968

CWE: 189