Ubuntu 22.04 LTS / 23.04 : .NET vulnerabilities (USN-6161-1)

high Nessus Plugin ID 177275

Synopsis

The remote Ubuntu host is missing one or more security updates.

Description

The remote Ubuntu 22.04 LTS / 22.10 / 23.04 host has packages installed that are affected by multiple vulnerabilities as referenced in the USN-6161-1 advisory.

- .NET, .NET Framework, and Visual Studio Elevation of Privilege Vulnerability (CVE-2023-24936)

- .NET, .NET Framework, and Visual Studio Denial of Service Vulnerability (CVE-2023-29331)

- NuGet Client Remote Code Execution Vulnerability (CVE-2023-29337)

- .NET and Visual Studio Elevation of Privilege Vulnerability (CVE-2023-32032)

- .NET and Visual Studio Remote Code Execution Vulnerability (CVE-2023-33128)

Note that Nessus has not tested for these issues but has instead relied only on the application's self-reported version number.

Solution

Update the affected packages.

See Also

https://ubuntu.com/security/notices/USN-6161-1

Plugin Details

Severity: High

ID: 177275

File Name: ubuntu_USN-6161-1.nasl

Version: 1.5

Type: local

Agent: unix

Published: 6/14/2023

Updated: 10/23/2023

Supported Sensors: Frictionless Assessment AWS, Frictionless Assessment Azure, Frictionless Assessment Agent, Nessus Agent, Agentless Assessment, Nessus

Risk Information

VPR

Risk Factor: Medium

Score: 6.7

CVSS v2

Risk Factor: High

Base Score: 7.6

Temporal Score: 5.6

Vector: CVSS2#AV:N/AC:H/Au:N/C:C/I:C/A:C

CVSS Score Source: CVE-2023-24936

CVSS v3

Risk Factor: High

Base Score: 7.5

Temporal Score: 6.5

Vector: CVSS:3.0/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:H

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

CPE: p-cpe:/a:canonical:ubuntu_linux:dotnet-hostfxr-6.0, p-cpe:/a:canonical:ubuntu_linux:dotnet-targeting-pack-7.0, p-cpe:/a:canonical:ubuntu_linux:dotnet-templates-6.0, cpe:/o:canonical:ubuntu_linux:22.04:-:lts, p-cpe:/a:canonical:ubuntu_linux:dotnet-hostfxr-7.0, p-cpe:/a:canonical:ubuntu_linux:dotnet-sdk-6.0, p-cpe:/a:canonical:ubuntu_linux:dotnet6, cpe:/o:canonical:ubuntu_linux:23.04, p-cpe:/a:canonical:ubuntu_linux:dotnet-host-7.0, p-cpe:/a:canonical:ubuntu_linux:dotnet-sdk-6.0-source-built-artifacts, p-cpe:/a:canonical:ubuntu_linux:dotnet-apphost-pack-6.0, p-cpe:/a:canonical:ubuntu_linux:aspnetcore-runtime-7.0, p-cpe:/a:canonical:ubuntu_linux:dotnet-host, p-cpe:/a:canonical:ubuntu_linux:aspnetcore-targeting-pack-6.0, p-cpe:/a:canonical:ubuntu_linux:aspnetcore-targeting-pack-7.0, p-cpe:/a:canonical:ubuntu_linux:dotnet-sdk-7.0, p-cpe:/a:canonical:ubuntu_linux:dotnet-targeting-pack-6.0, p-cpe:/a:canonical:ubuntu_linux:dotnet-sdk-7.0-source-built-artifacts, p-cpe:/a:canonical:ubuntu_linux:dotnet-runtime-6.0, p-cpe:/a:canonical:ubuntu_linux:aspnetcore-runtime-6.0, p-cpe:/a:canonical:ubuntu_linux:dotnet-apphost-pack-7.0, p-cpe:/a:canonical:ubuntu_linux:dotnet7, p-cpe:/a:canonical:ubuntu_linux:netstandard-targeting-pack-2.1, p-cpe:/a:canonical:ubuntu_linux:dotnet-runtime-7.0, p-cpe:/a:canonical:ubuntu_linux:dotnet-templates-7.0, p-cpe:/a:canonical:ubuntu_linux:netstandard-targeting-pack-2.1-7.0

Required KB Items: Host/cpu, Host/Debian/dpkg-l, Host/Ubuntu, Host/Ubuntu/release

Exploit Ease: No known exploits are available

Patch Publication Date: 6/13/2023

Vulnerability Publication Date: 6/13/2023

Reference Information

CVE: CVE-2023-24936, CVE-2023-29331, CVE-2023-29337, CVE-2023-32032, CVE-2023-33128

IAVA: 2023-A-0291-S, 2023-A-0298-S, 2023-A-0311

USN: 6161-1