Apache Tomcat 4.x < 4.1.36 Multiple Vulnerabilities

medium Nessus Plugin ID 17726


The remote Apache Tomcat server is affected by multiple vulnerabilities.


According to its self-reported version number, the instance of Apache Tomcat 4.x listening on the remote host is prior to 4.1.36. It is, therefore, affected by the following vulnerabilities :

- Requests containing multiple 'content-length' headers are not rejected as invalid. This error can allow web-cache poisoning, cross-site scripting attacks and information disclosure. (CVE-2005-2090)

- An input sanitization error exists that can allow disclosure of sensitive information via directory traversal. This vulnerability is exposed when the server is configured to use the 'Proxy' module.

- 'Accept-Language' headers are not validated properly, which can allow cross-site scripting attacks.

Note that Nessus has not tested for these issues but has instead relied only on the application's self-reported version number.


Update to Apache Tomcat version 4.1.36 or later.

See Also


Plugin Details

Severity: Medium

ID: 17726

File Name: tomcat_4_1_36.nasl

Version: 1.15

Type: combined

Agent: windows, macosx, unix

Family: Web Servers

Published: 11/18/2011

Updated: 4/11/2022

Configuration: Enable thorough checks

Supported Sensors: Nessus Agent

Risk Information


Risk Factor: Low

Score: 2.2


Risk Factor: Medium

Base Score: 5

Temporal Score: 3.9

Vector: AV:N/AC:L/Au:N/C:P/I:N/A:N

Temporal Vector: E:POC/RL:OF/RC:C

CVSS Score Source: CVE-2005-2090


Risk Factor: Medium

Base Score: 5.3

Temporal Score: 4.8

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N

Temporal Vector: E:P/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:apache:tomcat

Required KB Items: installed_sw/Apache Tomcat

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 4/7/2007

Vulnerability Publication Date: 6/6/2005

Reference Information

CVE: CVE-2005-2090, CVE-2007-0450, CVE-2007-1358

BID: 13873, 22960, 24524

CWE: 22, 79