Fortinet Fortigate - Heap buffer overflow in sslvpn pre-authentication (FG-IR-23-097)

critical Nessus Plugin ID 177116

Synopsis

Fortinet Firewall is missing one or more security-related updates.

Description

The version of Fortigate installed on the remote host is prior to tested version. It is, therefore, affected by a vulnerability as referenced in the FG-IR-23-097 advisory.

- A heap-based buffer overflow vulnerability [CWE-122] in FortiOS and FortiProxy SSL-VPN may allow a remote attacker to execute arbitrary code or commands via specifically crafted requests. (CVE-2023-27997)

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.

Solution

Please upgrade to FortiOS-6K7K version 7.0.12 or above Please upgrade to FortiOS-6K7K version 6.4.13 or above Please upgrade to FortiOS-6K7K version 6.2.15 or above Please upgrade to FortiOS-6K7K version 6.0.17 or above Please upgrade to FortiProxy version 7.2.4 or above Please upgrade to FortiProxy version 7.0.10 or above Please upgrade to FortiOS version 7.4.0 or above Please upgrade to FortiOS version 7.2.5 or above Please upgrade to FortiOS version 7.0.12 or above Please upgrade to FortiOS version 6.4.13 or above Please upgrade to FortiOS version 6.2.14 or above Please upgrade to FortiOS version 6.0.17 or above Alternatively, apply one of the workarounds outlined in the linked advisory.

See Also

https://www.fortiguard.com/psirt/FG-IR-23-097

Plugin Details

Severity: Critical

ID: 177116

File Name: fortigate_FG-IR-23-097.nasl

Version: 1.10

Type: local

Family: Firewalls

Published: 6/12/2023

Updated: 1/30/2024

Supported Sensors: Nessus

Risk Information

VPR

Risk Factor: Critical

Score: 9.2

CVSS v2

Risk Factor: Critical

Base Score: 10

Temporal Score: 8.7

Vector: CVSS2#AV:N/AC:L/Au:N/C:C/I:C/A:C

CVSS Score Source: CVE-2023-27997

CVSS v3

Risk Factor: Critical

Base Score: 9.8

Temporal Score: 9.4

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: CVSS:3.0/E:H/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:fortinet:fortiproxy

Required KB Items: Host/Fortigate/model, Host/Fortigate/version

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 6/12/2023

Vulnerability Publication Date: 6/12/2023

CISA Known Exploited Vulnerability Due Dates: 7/4/2023

Reference Information

CVE: CVE-2023-27997

IAVA: 2023-A-0281-S