Slackware Linux 15.0 / current texlive Vulnerability (SSA:2023-144-01)

high Nessus Plugin ID 176353

Synopsis

The remote Slackware Linux host is missing a security update to texlive.

Description

The version of texlive installed on the remote host is prior to 2023.230322. It is, therefore, affected by a vulnerability as referenced in the SSA:2023-144-01 advisory.

- LuaTeX before 1.17.0 allows execution of arbitrary shell commands when compiling a TeX file obtained from an untrusted source. This occurs because luatex-core.lua lets the original io.popen be accessed. This also affects TeX Live before 2023 r66984 and MiKTeX before 23.5. (CVE-2023-32700)

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.

Solution

Upgrade the affected texlive package.

See Also

http://www.nessus.org/u?faea03c7

Plugin Details

Severity: High

ID: 176353

File Name: Slackware_SSA_2023-144-01.nasl

Version: 1.0

Type: local

Published: 5/25/2023

Updated: 5/25/2023

Supported Sensors: Nessus

Risk Information

VPR

Risk Factor: Medium

Score: 5.9

CVSS v2

Risk Factor: High

Base Score: 7.2

Temporal Score: 5.3

Vector: CVSS2#AV:L/AC:L/Au:N/C:C/I:C/A:C

CVSS Score Source: CVE-2023-32700

CVSS v3

Risk Factor: High

Base Score: 7.8

Temporal Score: 6.8

Vector: CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/o:slackware:slackware_linux:15.0, p-cpe:/a:slackware:slackware_linux:texlive, cpe:/o:slackware:slackware_linux

Required KB Items: Host/local_checks_enabled, Host/Slackware/release, Host/Slackware/packages

Exploit Ease: No known exploits are available

Patch Publication Date: 5/24/2023

Vulnerability Publication Date: 5/20/2023

Reference Information

CVE: CVE-2023-32700