AlmaLinux 9 : emacs (ALSA-2023:2074)

high Nessus Plugin ID 175031

Synopsis

The remote AlmaLinux host is missing a security update.

Description

The remote AlmaLinux 9 host has packages installed that are affected by a vulnerability as referenced in the ALSA-2023:2074 advisory.

- org-babel-execute:latex in ob-latex.el in Org Mode through 9.6.1 for GNU Emacs allows attackers to execute arbitrary commands via a file name or directory name that contains shell metacharacters. (CVE-2023-28617)

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.

Solution

Update the affected packages.

See Also

https://errata.almalinux.org/9/ALSA-2023-2074.html

Plugin Details

Severity: High

ID: 175031

File Name: alma_linux_ALSA-2023-2074.nasl

Version: 1.0

Type: local

Published: 5/3/2023

Updated: 5/3/2023

Supported Sensors: Nessus

Risk Information

VPR

Risk Factor: Medium

Score: 6.7

CVSS v2

Risk Factor: High

Base Score: 7.2

Temporal Score: 5.3

Vector: CVSS2#AV:L/AC:L/Au:N/C:C/I:C/A:C

CVSS Score Source: CVE-2023-28617

CVSS v3

Risk Factor: High

Base Score: 7.8

Temporal Score: 6.8

Vector: CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/o:alma:linux:9::supplementary, p-cpe:/a:alma:linux:emacs, p-cpe:/a:alma:linux:emacs-common, p-cpe:/a:alma:linux:emacs-filesystem, p-cpe:/a:alma:linux:emacs-lucid, p-cpe:/a:alma:linux:emacs-nox, cpe:/o:alma:linux:9, cpe:/o:alma:linux:9::appstream, cpe:/o:alma:linux:9::baseos, cpe:/o:alma:linux:9::crb, cpe:/o:alma:linux:9::highavailability, cpe:/o:alma:linux:9::nfv, cpe:/o:alma:linux:9::realtime, cpe:/o:alma:linux:9::resilientstorage, cpe:/o:alma:linux:9::sap, cpe:/o:alma:linux:9::sap_hana

Required KB Items: Host/local_checks_enabled, Host/cpu, Host/AlmaLinux/release, Host/AlmaLinux/rpm-list

Exploit Ease: No known exploits are available

Patch Publication Date: 5/2/2023

Vulnerability Publication Date: 3/19/2023

Reference Information

CVE: CVE-2023-28617

CWE: 77