SUSE SLES15 Security Update : ceph (SUSE-SU-2023:1580-1)

critical Nessus Plugin ID 173448

Language:

Synopsis

The remote SUSE host is missing one or more security updates.

Description

The remote SUSE Linux SLES15 host has packages installed that are affected by multiple vulnerabilities as referenced in the SUSE-SU-2023:1580-1 advisory.

- A flaw was found in Openstack manilla owning a Ceph File system share, which enables the owner to read/write any manilla share or entire file system. The vulnerability is due to a bug in the volumes plugin in Ceph Manager. This allows an attacker to compromise Confidentiality and Integrity of a file system. Fixed in RHCS 5.2 and Ceph 17.2.2. (CVE-2022-0670)

- A privilege escalation flaw was found in Ceph. Ceph-crash.service allows a local attacker to escalate privileges to root in the form of a crash dump, and dump privileged information. (CVE-2022-3650)

- A flaw was found in Ceph, relating to the URL processing on RGW backends. An attacker can exploit the URL processing by providing a null URL to crash the RGW, causing a denial of service. (CVE-2022-3854)

Note that Nessus has not tested for these issues but has instead relied only on the application's self-reported version number.

Solution

Update the affected packages.

See Also

https://bugzilla.suse.com/1187748

https://bugzilla.suse.com/1188911

https://bugzilla.suse.com/1192838

https://bugzilla.suse.com/1192840

https://bugzilla.suse.com/1196046

https://bugzilla.suse.com/1199183

https://bugzilla.suse.com/1200262

https://bugzilla.suse.com/1200317

https://bugzilla.suse.com/1200501

https://bugzilla.suse.com/1200978

https://bugzilla.suse.com/1201604

https://bugzilla.suse.com/1201797

https://bugzilla.suse.com/1201837

https://bugzilla.suse.com/1201976

https://bugzilla.suse.com/1202077

https://bugzilla.suse.com/1202292

https://bugzilla.suse.com/1203375

https://bugzilla.suse.com/1204430

https://bugzilla.suse.com/1205025

https://bugzilla.suse.com/1205436

https://bugzilla.suse.com/1206158

https://lists.suse.com/pipermail/sle-updates/2023-March/028381.html

https://www.suse.com/security/cve/CVE-2022-0670

https://www.suse.com/security/cve/CVE-2022-3650

https://www.suse.com/security/cve/CVE-2022-3854

Plugin Details

Severity: Critical

ID: 173448

File Name: suse_SU-2023-1580-1.nasl

Version: 1.2

Type: local

Agent: unix

Published: 3/28/2023

Updated: 7/12/2023

Supported Sensors: Frictionless Assessment AWS, Frictionless Assessment Azure, Frictionless Assessment Agent, Nessus Agent, Agentless Assessment, Nessus

Risk Information

VPR

Risk Factor: Medium

Score: 6.7

CVSS v2

Risk Factor: High

Base Score: 9.4

Temporal Score: 7.4

Vector: CVSS2#AV:N/AC:L/Au:N/C:C/I:C/A:N

CVSS Score Source: CVE-2022-0670

CVSS v3

Risk Factor: Critical

Base Score: 9.1

Temporal Score: 8.2

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N

Temporal Vector: CVSS:3.0/E:P/RL:O/RC:C

Vulnerability Information

CPE: cpe:/o:novell:suse_linux:15, p-cpe:/a:novell:suse_linux:ceph-common, p-cpe:/a:novell:suse_linux:librados2, p-cpe:/a:novell:suse_linux:librbd1, p-cpe:/a:novell:suse_linux:libcephfs-devel, p-cpe:/a:novell:suse_linux:libcephfs2, p-cpe:/a:novell:suse_linux:librados-devel, p-cpe:/a:novell:suse_linux:libradospp-devel, p-cpe:/a:novell:suse_linux:librbd-devel, p-cpe:/a:novell:suse_linux:librgw-devel, p-cpe:/a:novell:suse_linux:librgw2, p-cpe:/a:novell:suse_linux:python3-ceph-argparse, p-cpe:/a:novell:suse_linux:python3-cephfs, p-cpe:/a:novell:suse_linux:python3-rados, p-cpe:/a:novell:suse_linux:python3-rbd, p-cpe:/a:novell:suse_linux:python3-rgw, p-cpe:/a:novell:suse_linux:rados-objclass-devel, p-cpe:/a:novell:suse_linux:rbd-nbd, p-cpe:/a:novell:suse_linux:python3-ceph-common

Required KB Items: Host/local_checks_enabled, Host/cpu, Host/SuSE/release, Host/SuSE/rpm-list

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 3/27/2023

Vulnerability Publication Date: 7/25/2022

Reference Information

CVE: CVE-2022-0670, CVE-2022-3650, CVE-2022-3854

SuSE: SUSE-SU-2023:1580-1