MySQL < 4.0.24 / 4.1.10a Multiple Vulnerabilities

Medium Nessus Plugin ID 17313

Synopsis

The remote database server is affected by multiple vulnerabilities.

Description

The remote host is running a version of MySQL which older than version 4.0.24 or 4.1.10a. Such versions are potentially affected by multiple issues.

- MySQL uses predictable file names when creating temporary tables, which allows local users with 'CREATE TEMPORARY TABLE' privileges to overwrite arbitrary files via a symlink attack. (CVE-2005-0711)

- A flaw exists that may allow a malicious user to gain access to unauthorized privileges when an authenticated user with 'INSERT' and 'DELETE' privileges bypasses library path restrictions using 'INSERT INTO' to modify the 'mysql.func' table. (CVE-2005-0709)

- A flaw exists that may allow a mlicious user to load arbitrary libraries when an authenticated user with 'INSERT' and 'DELETE' privileges use the 'CREATE FUNCTION' command to specify and load an arbitrary custom library. (CVE-2005-0710)

Solution

Upgrade to MySQL 4.0.24, 4.1.10a, or later as this reportedly fixes the issue.

See Also

http://support.apple.com/kb/TA23465?viewlocale=en_US

http://seclists.org/vulnwatch/2005/q1/81

http://seclists.org/vulnwatch/2005/q1/82

http://seclists.org/vulnwatch/2005/q1/83

Plugin Details

Severity: Medium

ID: 17313

File Name: mysql_multiple_flaws4.nasl

Version: $Revision: 1.19 $

Type: remote

Family: Databases

Published: 2005/03/11

Modified: 2016/10/05

Dependencies: 10719

Risk Information

Risk Factor: Medium

CVSSv2

Base Score: 4.6

Temporal Score: 3.8

Vector: CVSS2#AV:L/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:F/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:mysql:mysql

Required KB Items: Settings/ParanoidReport

Exploit Available: true

Exploit Ease: Exploits are available

Vulnerability Publication Date: 2005/03/11

Reference Information

CVE: CVE-2005-0709, CVE-2005-0710, CVE-2005-0711

BID: 12781

OSVDB: 14676, 14677, 14678