SUSE SLES12 Security Update : nrpe (SUSE-SU-2023:0586-1)

low Nessus Plugin ID 172044

Language:

Synopsis

The remote SUSE host is missing a security update.

Description

The remote SUSE Linux SLES12 / SLES_SAP12 host has packages installed that are affected by a vulnerability as referenced in the SUSE-SU-2023:0586-1 advisory.

- The TLS protocol 1.2 and earlier, when a DHE_EXPORT ciphersuite is enabled on a server but not on a client, does not properly convey a DHE_EXPORT choice, which allows man-in-the-middle attackers to conduct cipher-downgrade attacks by rewriting a ClientHello with DHE replaced by DHE_EXPORT and then rewriting a ServerHello with DHE_EXPORT replaced by DHE, aka the Logjam issue. (CVE-2015-4000)

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.

Solution

Update the affected monitoring-plugins-nrpe and / or nrpe packages.

See Also

https://bugzilla.suse.com/931600

https://bugzilla.suse.com/938906

https://www.suse.com/security/cve/CVE-2015-4000

http://www.nessus.org/u?e3bc55ab

Plugin Details

Severity: Low

ID: 172044

File Name: suse_SU-2023-0586-1.nasl

Version: 1.4

Type: local

Agent: unix

Published: 3/2/2023

Updated: 7/14/2023

Supported Sensors: Agentless Assessment, Frictionless Assessment Agent, Frictionless Assessment AWS, Frictionless Assessment Azure, Nessus Agent, Nessus

Risk Information

VPR

Risk Factor: Low

Score: 3.9

CVSS v2

Risk Factor: Medium

Base Score: 4.3

Temporal Score: 3.2

Vector: CVSS2#AV:N/AC:M/Au:N/C:N/I:P/A:N

CVSS Score Source: CVE-2015-4000

CVSS v3

Risk Factor: Low

Base Score: 3.7

Temporal Score: 3.2

Vector: CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:L/A:N

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

CPE: p-cpe:/a:novell:suse_linux:monitoring-plugins-nrpe, p-cpe:/a:novell:suse_linux:nrpe, cpe:/o:novell:suse_linux:12

Required KB Items: Host/local_checks_enabled, Host/cpu, Host/SuSE/release, Host/SuSE/rpm-list

Exploit Ease: No known exploits are available

Patch Publication Date: 3/1/2023

Vulnerability Publication Date: 5/19/2015

Reference Information

CVE: CVE-2015-4000

SuSE: SUSE-SU-2023:0586-1