GitLab 14.1 < 15.6.8 / 15.7 < 15.7.7 / 15.8 < 15.8.2 (CVE-2023-23946)

high Nessus Plugin ID 171883


The GitLab instance installed on the remote host is affected by vulnerability.


The version of GitLab installed on the remote host is between 14.1 to 15.6.8, prior to 15.7.7, prior to 15.8.2. It is, therefore, affected by a vulnerability as referenced in the CRITICAL-SECURITY-RELEASE-GITLAB-15-8-2-RELEASED advisory.

- A attacker can add a specially crafted input to git apply to allowing it to overwrite paths outside the working tree. (CVE-2023-23946)

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.


Upgrade to GitLab version 15.6.8, 15.7.7, 15.8.2 or later.

See Also

Plugin Details

Severity: High

ID: 171883

File Name: gitlab_CVE-2023-23946.nasl

Version: 1.2

Type: combined

Agent: unix

Family: CGI abuses

Published: 2/24/2023

Updated: 9/11/2023

Configuration: Enable thorough checks

Supported Sensors: Nessus Agent

Risk Information


Risk Factor: Medium

Score: 4.4


Risk Factor: High

Base Score: 7.8

Temporal Score: 6.1

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:C/A:N

CVSS Score Source: CVE-2023-23946


Risk Factor: High

Base Score: 7.5

Temporal Score: 6.7

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N

Temporal Vector: CVSS:3.0/E:P/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:gitlab:gitlab

Required KB Items: installed_sw/GitLab

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2/14/2023

Vulnerability Publication Date: 2/14/2023

Reference Information

CVE: CVE-2023-23946