Apache Struts 1.x < 1.2.9 Denial of Service (CVE-2006-1547)

high Nessus Plugin ID 170824


A web application running on the remote host uses a Java framework that is affected by a denial of service vulnerability.


The version of Apache Struts running on the remote host is 1.x prior to 1.2.9. It is, therefore, affected by a denial of service vulnerability in the ActionForm class.

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.


Upgrade to Apache Struts version 1.2.9 or later

Plugin Details

Severity: High

ID: 170824

File Name: struts_1_2_9.nasl

Version: 1.2

Type: combined

Agent: windows, macosx, unix

Family: Misc.

Published: 1/30/2023

Updated: 1/31/2023

Configuration: Enable thorough checks

Supported Sensors: Frictionless Assessment Agent, Nessus Agent, Nessus

Risk Information


Risk Factor: Medium

Score: 5.1


Risk Factor: High

Base Score: 7.8

Temporal Score: 6.8

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:C

CVSS Score Source: CVE-2006-1547


Risk Factor: High

Base Score: 7.5

Temporal Score: 7.2

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Temporal Vector: CVSS:3.0/E:H/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:apache:struts

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 3/30/2006

Vulnerability Publication Date: 3/30/2006

CISA Known Exploited Vulnerability Due Dates: 7/21/2022

Reference Information

CVE: CVE-2006-1547