AlmaLinux 8 : libXpm (ALSA-2023:0379)

high Nessus Plugin ID 170526

Synopsis

The remote AlmaLinux host is missing one or more security updates.

Description

The remote AlmaLinux 8 host has packages installed that are affected by multiple vulnerabilities as referenced in the ALSA-2023:0379 advisory.

- libXpm: compression commands depend on $PATH (CVE-2022-4883)

- libXpm: Runaway loop on width of 0 and enormous height (CVE-2022-44617)

- libXpm: Infinite loop on unclosed comments (CVE-2022-46285)

Note that Nessus has not tested for these issues but has instead relied only on the application's self-reported version number.

Solution

Update the affected libXpm and / or libXpm-devel packages.

See Also

https://errata.almalinux.org/8/ALSA-2023-0379.html

Plugin Details

Severity: High

ID: 170526

File Name: alma_linux_ALSA-2023-0379.nasl

Version: 1.4

Type: local

Published: 1/24/2023

Updated: 2/17/2023

Risk Information

VPR

Risk Factor: Medium

Score: 5.9

CVSS v2

Risk Factor: High

Base Score: 9

Temporal Score: 7

Vector: CVSS2#AV:N/AC:L/Au:S/C:C/I:C/A:C

CVSS Score Source: CVE-2022-4883

CVSS v3

Risk Factor: High

Base Score: 8.8

Temporal Score: 7.9

Vector: CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: CVSS:3.0/E:P/RL:O/RC:C

Vulnerability Information

CPE: cpe:/o:alma:linux:8, cpe:/o:alma:linux:8::appstream, p-cpe:/a:alma:linux:libxpm-devel, p-cpe:/a:alma:linux:libxpm

Required KB Items: Host/local_checks_enabled, Host/AlmaLinux/release, Host/AlmaLinux/rpm-list, Host/cpu

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 1/23/2023

Vulnerability Publication Date: 1/17/2023

Reference Information

CVE: CVE-2022-44617, CVE-2022-46285, CVE-2022-4883

CWE: 20, 426, 835