Slackware Linux 15.0 / current ruby Vulnerability (SSA:2022-328-01)

high Nessus Plugin ID 168190

Synopsis

The remote Slackware Linux host is missing a security update to ruby.

Description

The version of ruby installed on the remote host is prior to 3.0.5 / 3.1.3. It is, therefore, affected by a vulnerability as referenced in the SSA:2022-328-01 advisory.

- The cgi gem before 0.1.0.2, 0.2.x before 0.2.2, and 0.3.x before 0.3.5 for Ruby allows HTTP response splitting. This is relevant to applications that use untrusted user input either to generate an HTTP response or to create a CGI::Cookie object. (CVE-2021-33621)

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.

Solution

Upgrade the affected ruby package.

Plugin Details

Severity: High

ID: 168190

File Name: Slackware_SSA_2022-328-01.nasl

Version: 1.3

Type: local

Published: 11/25/2022

Updated: 11/28/2022

Risk Information

VPR

Risk Factor: Medium

Score: 6.7

CVSS v2

Risk Factor: High

Base Score: 9

Temporal Score: 6.7

Vector: AV:N/AC:L/Au:S/C:C/I:C/A:C

Temporal Vector: E:U/RL:OF/RC:C

CVSS Score Source: CVE-2021-33621

CVSS v3

Risk Factor: High

Base Score: 8.8

Temporal Score: 7.7

Vector: CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: E:U/RL:O/RC:C

Vulnerability Information

CPE: p-cpe:/a:slackware:slackware_linux:ruby, cpe:/o:slackware:slackware_linux, cpe:/o:slackware:slackware_linux:15.0

Required KB Items: Host/local_checks_enabled, Host/Slackware/release, Host/Slackware/packages

Exploit Ease: No known exploits are available

Vulnerability Publication Date: 11/18/2022

Reference Information

CVE: CVE-2021-33621