Slackware Linux 15.0 / current php Multiple Vulnerabilities (SSA:2022-314-01)

critical Nessus Plugin ID 167280


The remote Slackware Linux host is missing a security update to php.


The version of php installed on the remote host is prior to 7.4.33. It is, therefore, affected by multiple vulnerabilities as referenced in the SSA:2022-314-01 advisory.

- The Keccak XKCP SHA-3 reference implementation before fdc6fef has an integer overflow and resultant buffer overflow that allows attackers to execute arbitrary code or eliminate expected cryptographic properties.
This occurs in the sponge function interface. (CVE-2022-37454)

- The vulnerability exists due to a boundary condition within the imageloadfont() function. A remote attacker can pass specially crafted data to the web application, trigger an out-of-bounds read error and read contents of memory on the system. (CVE-2022-31630)

Note that Nessus has not tested for these issues but has instead relied only on the application's self-reported version number.


Upgrade the affected php package.

Plugin Details

Severity: Critical

ID: 167280

File Name: Slackware_SSA_2022-314-01.nasl

Version: 1.7

Type: local

Published: 11/11/2022

Updated: 10/4/2023

Supported Sensors: Nessus

Risk Information


Risk Factor: Medium

Score: 6.7


Risk Factor: Critical

Base Score: 10

Temporal Score: 7.8

Vector: CVSS2#AV:N/AC:L/Au:N/C:C/I:C/A:C

CVSS Score Source: CVE-2022-37454


Risk Factor: Critical

Base Score: 9.8

Temporal Score: 8.8

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: CVSS:3.0/E:P/RL:O/RC:C

Vulnerability Information

CPE: p-cpe:/a:slackware:slackware_linux:php, cpe:/o:slackware:slackware_linux, cpe:/o:slackware:slackware_linux:15.0

Required KB Items: Host/local_checks_enabled, Host/Slackware/release, Host/Slackware/packages

Exploit Available: true

Exploit Ease: Exploits are available

Vulnerability Publication Date: 10/21/2022

Reference Information

CVE: CVE-2022-31630, CVE-2022-37454

IAVA: 2022-A-0455-S, 2022-A-0515-S