Slackware Linux 15.0 / current xfce4-settings Vulnerability (SSA:2022-313-02)

critical Nessus Plugin ID 167230


The remote Slackware Linux host is missing a security update to xfce4-settings.


The version of xfce4-settings installed on the remote host is prior to 4.16.4. It is, therefore, affected by a vulnerability as referenced in the SSA:2022-313-02 advisory.

- In Xfce xfce4-settings before 4.16.4 and 4.17.x before 4.17.1, there is an argument injection vulnerability in xfce4-mime-helper. (CVE-2022-45062)

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.


Upgrade the affected xfce4-settings package.

Plugin Details

Severity: Critical

ID: 167230

File Name: Slackware_SSA_2022-313-02.nasl

Version: 1.3

Type: local

Published: 11/9/2022

Updated: 11/24/2022

Supported Sensors: Nessus

Risk Information


Risk Factor: Medium

Score: 6.7


Risk Factor: Critical

Base Score: 10

Temporal Score: 7.4

Vector: CVSS2#AV:N/AC:L/Au:N/C:C/I:C/A:C

CVSS Score Source: CVE-2022-45062


Risk Factor: Critical

Base Score: 9.8

Temporal Score: 8.5

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

CPE: p-cpe:/a:slackware:slackware_linux:xfce4-settings, cpe:/o:slackware:slackware_linux, cpe:/o:slackware:slackware_linux:15.0

Required KB Items: Host/local_checks_enabled, Host/Slackware/release, Host/Slackware/packages

Exploit Ease: No known exploits are available

Vulnerability Publication Date: 11/9/2022

Reference Information

CVE: CVE-2022-45062