Oracle Database Server (Oct 2022 CPU)

critical Nessus Plugin ID 166370

Synopsis

The remote host is affected by multiple vulnerabilities

Description

The 19c and 21c versions of Oracle Database Server installed on the remote host are affected by multiple vulnerabilities as referenced in the October 2022 CPU advisory.

- Vulnerability in the Oracle Database - Machine Learning (Numpy) component of Oracle Database Server. The supported version that is affected is 21c. Easily exploitable vulnerability allows low privileged attacker having Create Session privilege with network access via Oracle Net to compromise Oracle Database - Machine Learning (Numpy). (CVE-2021-41495)

- Vulnerability in the Spatial and Graph (jackson-databind) component of Oracle Database Server. Supported versions that are affected are 19c and 21c. Easily exploitable vulnerability allows low privileged attacker having Authenticated User privilege with network access via HTTP to compromise Spatial and Graph (jackson-databind). Successful attacks of this vulnerability can result in unauthorized ability to cause a hang or frequently repeatable crash (complete DOS) of Spatial and Graph (jackson-databind).
(CVE-2020-36518)

- Vulnerability in the Oracle Notification Server (PCRE2) component of Oracle Database Server. Supported versions that are affected are 19c and 21c. Easily exploitable vulnerability allows low privileged attacker having Subscriber privilege with network access via HTTP to compromise Oracle Notification Server (PCRE2). Successful attacks of this vulnerability can result in unauthorized ability to cause a hang or frequently repeatable crash (complete DOS) of Oracle Notification Server (PCRE2).
Note: This vulnerability applies to Windows systems only. (CVE-2022-1587)

- Vulnerability in the Oracle Database - Advanced Queuing component of Oracle Database Server. The supported version that is affected is 19c. Easily exploitable vulnerability allows high privileged attacker having DBA user privilege with network access via Oracle Net to compromise Oracle Database - Advanced Queuing.
Successful attacks of this vulnerability can result in takeover of Oracle Database - Advanced Queuing.
(CVE-2022-21596)

- Vulnerability in the Oracle Database - Sharding component of Oracle Database Server. Supported versions that are affected are 19c and 21c. Easily exploitable vulnerability allows high privileged attacker having Local Logon privilege with network access via Local Logon to compromise Oracle Database - Sharding.
Successful attacks of this vulnerability can result in takeover of Oracle Database - Sharding.
(CVE-2022-21603)

Note that Nessus has not tested for these issues but has instead relied only on the application's self-reported version number.

Solution

Apply the appropriate patch according to the October 2022 Oracle Critical Patch Update advisory.

See Also

https://www.oracle.com/docs/tech/security-alerts/cpuoct2022cvrf.xml

https://www.oracle.com/security-alerts/cpuoct2022.html

Plugin Details

Severity: Critical

ID: 166370

File Name: oracle_rdbms_cpu_oct_2022.nasl

Version: 1.5

Type: local

Agent: windows, macosx, unix

Family: Databases

Published: 10/21/2022

Updated: 1/19/2023

Configuration: Enable thorough checks

Supported Sensors: Nessus Agent

Risk Information

VPR

Risk Factor: High

Score: 7.4

CVSS v2

Risk Factor: High

Base Score: 7.5

Temporal Score: 5.9

Vector: AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: E:POC/RL:OF/RC:C

CVSS Score Source: CVE-2019-2904

CVSS v3

Risk Factor: Critical

Base Score: 9.8

Temporal Score: 8.8

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: E:P/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:oracle:database_server

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 10/18/2022

Vulnerability Publication Date: 10/18/2022

Reference Information

CVE: CVE-2019-2904, CVE-2020-13956, CVE-2020-36518, CVE-2021-3737, CVE-2021-4048, CVE-2021-25122, CVE-2021-25329, CVE-2021-30129, CVE-2021-41495, CVE-2021-41496, CVE-2022-1586, CVE-2022-1587, CVE-2022-2047, CVE-2022-2048, CVE-2022-21540, CVE-2022-21541, CVE-2022-21549, CVE-2022-21596, CVE-2022-21603, CVE-2022-21606, CVE-2022-34169, CVE-2022-34305, CVE-2022-39419

IAVA: 2022-A-0424-S

CEA-ID: CEA-2021-0025