Slackware Linux 15.0 / current vim Vulnerability (SSA:2022-269-02)

high Nessus Plugin ID 165480

Synopsis

The remote Slackware Linux host is missing a security update to vim.

Description

The version of vim installed on the remote host is prior to 9.0.0594. It is, therefore, affected by a vulnerability as referenced in the SSA:2022-269-02 advisory.

- Stack-based Buffer Overflow in GitHub repository vim/vim prior to 9.0.0577. (CVE-2022-3296)

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.

Solution

Upgrade the affected vim package.

Plugin Details

Severity: High

ID: 165480

File Name: Slackware_SSA_2022-269-02.nasl

Version: 1.3

Type: local

Published: 9/26/2022

Updated: 9/29/2022

Risk Information

VPR

Risk Factor: Medium

Score: 6.7

CVSS v3

Risk Factor: High

Base Score: 7.8

Temporal Score: 6.8

Vector: CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

Temporal Vector: E:U/RL:O/RC:C

CVSS Score Source: CVE-2022-3296

Vulnerability Information

CPE: p-cpe:/a:slackware:slackware_linux:vim, p-cpe:/a:slackware:slackware_linux:vim-gvim, cpe:/o:slackware:slackware_linux, cpe:/o:slackware:slackware_linux:15.0

Required KB Items: Host/local_checks_enabled, Host/Slackware/release, Host/Slackware/packages

Exploit Ease: No known exploits are available

Vulnerability Publication Date: 9/25/2022

Reference Information

CVE: CVE-2022-3296