ISC BIND 9.9.4-S1 < 9.16.33-S1 / 9.8.4 < 9.16.33 / 9.16.8-S1 < 9.16.33-S1 Memory Exhaustion (cve-2022-38177)

high Nessus Plugin ID 165301

Synopsis

The remote name server is affected by a memory exhaustion vulnerability vulnerability.

Description

The version of ISC BIND installed on the remote host is prior to tested version. It is, therefore, affected by a vulnerability as referenced in the cve-2022-38177 advisory.

- By spoofing the target resolver with responses that have a malformed ECDSA signature, an attacker can trigger a small memory leak. It is possible to gradually erode available memory to the point where named crashes for lack of resources. (CVE-2022-38177)

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.

Solution

Upgrade to ISC BIND version 9.16.33 / 9.16.33-S1 or later.

See Also

https://kb.isc.org/v1/docs/cve-2022-38177

Plugin Details

Severity: High

ID: 165301

File Name: bind9_91633_s1.nasl

Version: 1.3

Type: remote

Family: DNS

Published: 9/22/2022

Updated: 9/23/2022

Configuration: Enable paranoid mode

Risk Information

VPR

Risk Factor: Medium

Score: 4.4

CVSS v2

Risk Factor: Medium

Base Score: 5

Temporal Score: 3.7

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:P

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

CVSS Score Source: CVE-2022-38177

CVSS v3

Risk Factor: High

Base Score: 7.5

Temporal Score: 6.5

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:2.3:a:isc:bind:*:*:*:*:*:*:*:*

Required KB Items: Settings/ParanoidReport, bind/version

Exploit Ease: No known exploits are available

Patch Publication Date: 9/21/2022

Vulnerability Publication Date: 9/21/2022

Reference Information

CVE: CVE-2022-38177

IAVA: 2022-A-0387