Slackware Linux 14.0 / 14.1 / 14.2 / 15.0 / current expat Vulnerability (SSA:2022-263-01)

critical Nessus Plugin ID 165265

Synopsis

The remote Slackware Linux host is missing a security update to expat.

Description

The version of expat installed on the remote host is prior to 2.4.3 / 2.4.9. It is, therefore, affected by a vulnerability as referenced in the SSA:2022-263-01 advisory.

- libexpat before 2.4.9 has a use-after-free in the doContent function in xmlparse.c. (CVE-2022-40674)

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.

Solution

Upgrade the affected expat package.

Plugin Details

Severity: Critical

ID: 165265

File Name: Slackware_SSA_2022-263-01.nasl

Version: 1.3

Type: local

Published: 9/20/2022

Updated: 12/2/2022

Risk Information

VPR

Risk Factor: High

Score: 8.4

CVSS v2

Risk Factor: Critical

Base Score: 10

Temporal Score: 7.4

Vector: AV:N/AC:L/Au:N/C:C/I:C/A:C

Temporal Vector: E:U/RL:OF/RC:C

CVSS Score Source: CVE-2022-40674

CVSS v3

Risk Factor: Critical

Base Score: 9.8

Temporal Score: 8.5

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: E:U/RL:O/RC:C

Vulnerability Information

CPE: p-cpe:/a:slackware:slackware_linux:expat, cpe:/o:slackware:slackware_linux, cpe:/o:slackware:slackware_linux:14.0, cpe:/o:slackware:slackware_linux:14.1, cpe:/o:slackware:slackware_linux:14.2, cpe:/o:slackware:slackware_linux:15.0

Required KB Items: Host/local_checks_enabled, Host/Slackware/release, Host/Slackware/packages

Exploit Ease: No known exploits are available

Vulnerability Publication Date: 9/14/2022

Reference Information

CVE: CVE-2022-40674