FreeBSD : chromium -- multiple vulnerabilities (b59847e0-346d-11ed-8fe9-3065ec8fd3ec)

high Nessus Plugin ID 165089

Language:

Synopsis

The remote FreeBSD host is missing one or more security-related updates.

Description

The version of FreeBSD installed on the remote host is prior to tested version. It is, therefore, affected by multiple vulnerabilities as referenced in the b59847e0-346d-11ed-8fe9-3065ec8fd3ec advisory.

- Out of bounds write in Storage. (CVE-2022-3195)

- Use after free in PDF. (CVE-2022-3196, CVE-2022-3197, CVE-2022-3198)

- Use after free in Frames. (CVE-2022-3199)

- Heap buffer overflow in Internals. (CVE-2022-3200)

- Insufficient validation of untrusted input in DevTools. (CVE-2022-3201)

Note that Nessus has not tested for these issues but has instead relied only on the application's self-reported version number.

Solution

Update the affected packages.

See Also

http://www.nessus.org/u?fe4c0310

http://www.nessus.org/u?4710cc5f

Plugin Details

Severity: High

ID: 165089

File Name: freebsd_pkg_b59847e0346d11ed8fe93065ec8fd3ec.nasl

Version: 1.11

Type: local

Published: 9/14/2022

Updated: 10/25/2023

Supported Sensors: Nessus

Risk Information

VPR

Risk Factor: High

Score: 7.4

CVSS v2

Risk Factor: Critical

Base Score: 10

Temporal Score: 7.8

Vector: CVSS2#AV:N/AC:L/Au:N/C:C/I:C/A:C

CVSS Score Source: CVE-2022-3200

CVSS v3

Risk Factor: High

Base Score: 8.8

Temporal Score: 7.9

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

Temporal Vector: CVSS:3.0/E:P/RL:O/RC:C

Vulnerability Information

CPE: p-cpe:/a:freebsd:freebsd:chromium, cpe:/o:freebsd:freebsd

Required KB Items: Host/local_checks_enabled, Host/FreeBSD/release, Host/FreeBSD/pkg_info

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 9/14/2022

Vulnerability Publication Date: 9/14/2022

Reference Information

CVE: CVE-2022-3195, CVE-2022-3196, CVE-2022-3197, CVE-2022-3198, CVE-2022-3199, CVE-2022-3200, CVE-2022-3201

IAVA: 2022-A-0379-S, 2022-A-0388-S, 2022-A-0394-S