Slackware Linux 15.0 / current vim Vulnerability (SSA:2022-252-01)

medium Nessus Plugin ID 164938

Synopsis

The remote Slackware Linux host is missing a security update to vim.

Description

The version of vim installed on the remote host is prior to 9.0.0417. It is, therefore, affected by a vulnerability as referenced in the SSA:2022-252-01 advisory.

- NULL Pointer Dereference in GitHub repository vim/vim prior to 9.0.0404. (CVE-2022-3153)

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.

Solution

Upgrade the affected vim package.

Plugin Details

Severity: Medium

ID: 164938

File Name: Slackware_SSA_2022-252-01.nasl

Version: 1.4

Type: local

Published: 9/10/2022

Updated: 12/5/2022

Risk Information

VPR

Risk Factor: Medium

Score: 4.4

CVSS v2

Risk Factor: Medium

Base Score: 4.9

Temporal Score: 3.6

Vector: AV:L/AC:L/Au:N/C:N/I:N/A:C

Temporal Vector: E:U/RL:OF/RC:C

CVSS Score Source: CVE-2022-3153

CVSS v3

Risk Factor: Medium

Base Score: 5.5

Temporal Score: 4.8

Vector: CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H

Temporal Vector: E:U/RL:O/RC:C

Vulnerability Information

CPE: p-cpe:/a:slackware:slackware_linux:vim, p-cpe:/a:slackware:slackware_linux:vim-gvim, cpe:/o:slackware:slackware_linux, cpe:/o:slackware:slackware_linux:15.0

Required KB Items: Host/local_checks_enabled, Host/Slackware/release, Host/Slackware/packages

Exploit Ease: No known exploits are available

Vulnerability Publication Date: 9/8/2022

Reference Information

CVE: CVE-2022-3153