Slackware Linux 15.0 / current vim Vulnerability (SSA:2022-249-03)

high Nessus Plugin ID 164796


The remote Slackware Linux host is missing a security update to vim.


The version of vim installed on the remote host is prior to 9.0.0396. It is, therefore, affected by a vulnerability as referenced in the SSA:2022-249-03 advisory.

- Use After Free in GitHub repository vim/vim prior to 9.0.0360. (CVE-2022-3099)

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.


Upgrade the affected vim package.

Plugin Details

Severity: High

ID: 164796

File Name: Slackware_SSA_2022-249-03.nasl

Version: 1.4

Type: local

Published: 9/7/2022

Updated: 12/5/2022

Risk Information


Risk Factor: Medium

Score: 6.7


Risk Factor: High

Base Score: 7.2

Temporal Score: 5.3

Vector: AV:L/AC:L/Au:N/C:C/I:C/A:C

Temporal Vector: E:U/RL:OF/RC:C

CVSS Score Source: CVE-2022-3099


Risk Factor: High

Base Score: 7.8

Temporal Score: 6.8

Vector: CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

Temporal Vector: E:U/RL:O/RC:C

Vulnerability Information

CPE: p-cpe:/a:slackware:slackware_linux:vim, p-cpe:/a:slackware:slackware_linux:vim-gvim, cpe:/o:slackware:slackware_linux, cpe:/o:slackware:slackware_linux:15.0

Required KB Items: Host/local_checks_enabled, Host/Slackware/release, Host/Slackware/packages

Exploit Ease: No known exploits are available

Vulnerability Publication Date: 9/3/2022

Reference Information

CVE: CVE-2022-3099