Slackware Linux 15.0 / current hunspell Vulnerability (SSA:2022-235-01)

medium Nessus Plugin ID 164364


The remote Slackware Linux host is missing a security update to hunspell.


The version of hunspell installed on the remote host is prior to 1.7.1. It is, therefore, affected by a vulnerability as referenced in the SSA:2022-235-01 advisory.

- Hunspell 1.7.0 has an invalid read operation in SuggestMgr::leftcommonsubstring in suggestmgr.cxx.

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.


Upgrade the affected hunspell package.

Plugin Details

Severity: Medium

ID: 164364

File Name: Slackware_SSA_2022-235-01.nasl

Version: 1.2

Type: local

Published: 8/23/2022

Updated: 8/23/2022

Risk Information


Risk Factor: Medium

Score: 4.4


Risk Factor: Medium

Base Score: 4.3

Temporal Score: 3.2

Vector: CVSS2#AV:N/AC:M/Au:N/C:N/I:N/A:P

CVSS Score Source: CVE-2019-16707


Risk Factor: Medium

Base Score: 6.5

Temporal Score: 5.7

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

CPE: p-cpe:/a:slackware:slackware_linux:hunspell, cpe:/o:slackware:slackware_linux, cpe:/o:slackware:slackware_linux:15.0

Required KB Items: Host/local_checks_enabled, Host/Slackware/release, Host/Slackware/packages

Exploit Ease: No known exploits are available

Vulnerability Publication Date: 9/23/2019

Reference Information

CVE: CVE-2019-16707