Slackware Linux 15.0 / current vim Vulnerability (SSA:2022-232-01)

high Nessus Plugin ID 164325

Synopsis

The remote Slackware Linux host is missing a security update to vim.

Description

The version of vim installed on the remote host is prior to 8.2.4649 / 9.0.0231. It is, therefore, affected by a vulnerability as referenced in the SSA:2022-232-01 advisory.

- Use After Free in GitHub repository vim/vim prior to 9.0.0225. (CVE-2022-2889)

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.

Solution

Upgrade the affected vim package.

Plugin Details

Severity: High

ID: 164325

File Name: Slackware_SSA_2022-232-01.nasl

Version: 1.3

Type: local

Published: 8/22/2022

Updated: 12/6/2022

Risk Information

VPR

Risk Factor: Medium

Score: 5.9

CVSS v2

Risk Factor: High

Base Score: 7.2

Temporal Score: 5.3

Vector: AV:L/AC:L/Au:N/C:C/I:C/A:C

Temporal Vector: E:U/RL:OF/RC:C

CVSS Score Source: CVE-2022-2889

CVSS v3

Risk Factor: High

Base Score: 7.8

Temporal Score: 6.8

Vector: CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

Temporal Vector: E:U/RL:O/RC:C

Vulnerability Information

CPE: p-cpe:/a:slackware:slackware_linux:vim, p-cpe:/a:slackware:slackware_linux:vim-gvim, cpe:/o:slackware:slackware_linux, cpe:/o:slackware:slackware_linux:15.0

Required KB Items: Host/local_checks_enabled, Host/Slackware/release, Host/Slackware/packages

Exploit Ease: No known exploits are available

Vulnerability Publication Date: 8/19/2022

Reference Information

CVE: CVE-2022-2889