Slackware Linux 15.0 / current vim Multiple Vulnerabilities (SSA:2022-229-01)

high Nessus Plugin ID 164261


The remote Slackware Linux host is missing a security update to vim.


The version of vim installed on the remote host is prior to 8.2.4649 / 9.0.0223. It is, therefore, affected by multiple vulnerabilities as referenced in the SSA:2022-229-01 advisory.

- Out-of-bounds Read in GitHub repository vim/vim prior to 9.0.0211. (CVE-2022-2816)

- Use After Free in GitHub repository vim/vim prior to 9.0.0212. (CVE-2022-2817)

- Heap-based Buffer Overflow in GitHub repository vim/vim prior to 9.0.0210. (CVE-2022-2819)

Note that Nessus has not tested for these issues but has instead relied only on the application's self-reported version number.


Upgrade the affected vim package.

Plugin Details

Severity: High

ID: 164261

File Name: Slackware_SSA_2022-229-01.nasl

Version: 1.4

Type: local

Published: 8/18/2022

Updated: 10/13/2023

Supported Sensors: Nessus

Risk Information


Risk Factor: Medium

Score: 6.7


Risk Factor: High

Base Score: 7.2

Temporal Score: 5.6

Vector: CVSS2#AV:L/AC:L/Au:N/C:C/I:C/A:C

CVSS Score Source: CVE-2022-2819


Risk Factor: High

Base Score: 7.8

Temporal Score: 7

Vector: CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

Temporal Vector: CVSS:3.0/E:P/RL:O/RC:C

Vulnerability Information

CPE: p-cpe:/a:slackware:slackware_linux:vim, p-cpe:/a:slackware:slackware_linux:vim-gvim, cpe:/o:slackware:slackware_linux, cpe:/o:slackware:slackware_linux:15.0

Required KB Items: Host/local_checks_enabled, Host/Slackware/release, Host/Slackware/packages

Exploit Available: true

Exploit Ease: Exploits are available

Vulnerability Publication Date: 8/15/2022

Reference Information

CVE: CVE-2022-2816, CVE-2022-2817, CVE-2022-2819