SUSE SLED15 / SLES15 Security Update : harfbuzz (SUSE-SU-2022:2664-1)

medium Nessus Plugin ID 163881

Language:

Synopsis

The remote SUSE host is missing a security update.

Description

The remote SUSE Linux SLED15 / SLES15 host has packages installed that are affected by a vulnerability as referenced in the SUSE-SU-2022:2664-1 advisory.

- An integer overflow in the component hb-ot-shape-fallback.cc of Harfbuzz v4.3.0 allows attackers to cause a Denial of Service (DoS) via unspecified vectors. (CVE-2022-33068)

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.

Solution

Update the affected packages.

See Also

https://bugzilla.suse.com/1200900

https://www.suse.com/security/cve/CVE-2022-33068

http://www.nessus.org/u?53bbc325

Plugin Details

Severity: Medium

ID: 163881

File Name: suse_SU-2022-2664-1.nasl

Version: 1.2

Type: local

Agent: unix

Published: 8/5/2022

Updated: 8/5/2022

Supported Sensors: Nessus Agent

Risk Information

VPR

Risk Factor: Low

Score: 3.6

CVSS v2

Risk Factor: Medium

Base Score: 4.3

Temporal Score: 3.2

Vector: CVSS2#AV:N/AC:M/Au:N/C:N/I:N/A:P

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

CVSS Score Source: CVE-2022-33068

CVSS v3

Risk Factor: Medium

Base Score: 5.5

Temporal Score: 4.8

Vector: CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:2.3:o:novell:suse_linux:15:*:*:*:*:*:*:*, p-cpe:2.3:a:novell:suse_linux:harfbuzz-devel:*:*:*:*:*:*:*, p-cpe:2.3:a:novell:suse_linux:libharfbuzz-gobject0:*:*:*:*:*:*:*, p-cpe:2.3:a:novell:suse_linux:libharfbuzz-icu0:*:*:*:*:*:*:*, p-cpe:2.3:a:novell:suse_linux:libharfbuzz-subset0:*:*:*:*:*:*:*, p-cpe:2.3:a:novell:suse_linux:libharfbuzz0:*:*:*:*:*:*:*, p-cpe:2.3:a:novell:suse_linux:libharfbuzz0-32bit:*:*:*:*:*:*:*, p-cpe:2.3:a:novell:suse_linux:typelib-1_0-harfbuzz-0_0:*:*:*:*:*:*:*

Required KB Items: Host/local_checks_enabled, Host/cpu, Host/SuSE/release, Host/SuSE/rpm-list

Exploit Ease: No known exploits are available

Patch Publication Date: 8/4/2022

Vulnerability Publication Date: 6/23/2022

Reference Information

CVE: CVE-2022-33068

SuSE: SUSE-SU-2022:2664-1