Slackware Linux 15.0 / current gnutls Vulnerability (SSA:2022-210-01)

high Nessus Plugin ID 163635

Synopsis

The remote Slackware Linux host is missing a security update to gnutls.

Description

The version of gnutls installed on the remote host is prior to 3.7.7. It is, therefore, affected by a vulnerability as referenced in the SSA:2022-210-01 advisory.

- A vulnerability found in gnutls. This security flaw happens because of a double free error occurs during verification of pkcs7 signatures in gnutls_pkcs7_verify function. (CVE-2022-2509)

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.

Solution

Upgrade the affected gnutls package.

Plugin Details

Severity: High

ID: 163635

File Name: Slackware_SSA_2022-210-01.nasl

Version: 1.5

Type: local

Published: 7/29/2022

Updated: 3/21/2023

Supported Sensors: Nessus

Risk Information

VPR

Risk Factor: Medium

Score: 5.1

CVSS v2

Risk Factor: High

Base Score: 7.8

Temporal Score: 5.8

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:C

CVSS Score Source: CVE-2022-2509

CVSS v3

Risk Factor: High

Base Score: 7.5

Temporal Score: 6.5

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

CPE: p-cpe:/a:slackware:slackware_linux:gnutls, cpe:/o:slackware:slackware_linux, cpe:/o:slackware:slackware_linux:15.0

Required KB Items: Host/local_checks_enabled, Host/Slackware/release, Host/Slackware/packages

Exploit Ease: No known exploits are available

Reference Information

CVE: CVE-2022-2509