Slackware Linux 15.0 / current samba Multiple Vulnerabilities (SSA:2022-208-01)

high Nessus Plugin ID 163501

Synopsis

The remote Slackware Linux host is missing a security update to samba.

Description

The version of samba installed on the remote host is prior to 4.15.9 / 4.16.4. It is, therefore, affected by multiple vulnerabilities as referenced in the SSA:2022-208-01 advisory.

Note that Nessus has not tested for these issues but has instead relied only on the application's self-reported version number.

Solution

Upgrade the affected samba package.

Plugin Details

Severity: High

ID: 163501

File Name: Slackware_SSA_2022-208-01.nasl

Version: 1.6

Type: local

Published: 7/27/2022

Updated: 12/8/2022

Risk Information

VPR

Risk Factor: Medium

Score: 6.7

CVSS v2

Risk Factor: High

Base Score: 9.4

Temporal Score: 7

Vector: AV:N/AC:L/Au:N/C:C/I:N/A:C

Temporal Vector: E:U/RL:OF/RC:C

CVSS Score Source: CVE-2022-32745

CVSS v3

Risk Factor: High

Base Score: 8.8

Temporal Score: 7.7

Vector: CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: E:U/RL:O/RC:C

CVSS Score Source: CVE-2022-32744

Vulnerability Information

CPE: p-cpe:/a:slackware:slackware_linux:samba, cpe:/o:slackware:slackware_linux, cpe:/o:slackware:slackware_linux:15.0

Required KB Items: Host/local_checks_enabled, Host/Slackware/release, Host/Slackware/packages

Exploit Ease: No known exploits are available

Reference Information

CVE: CVE-2022-2031, CVE-2022-32742, CVE-2022-32744, CVE-2022-32745, CVE-2022-32746

IAVA: 2022-A-0299-S