Slackware Linux 15.0 / current xorg-server Multiple Vulnerabilities (SSA:2022-194-01)

high Nessus Plugin ID 163089

Synopsis

The remote Slackware Linux host is missing a security update to xorg-server.

Description

The version of xorg-server installed on the remote host is prior to 1.20.14. It is, therefore, affected by multiple vulnerabilities as referenced in the SSA:2022-194-01 advisory.

Note that Nessus has not tested for these issues but has instead relied only on the application's self-reported version number.

Solution

Upgrade the affected xorg-server package.

Plugin Details

Severity: High

ID: 163089

File Name: Slackware_SSA_2022-194-01.nasl

Version: 1.2

Type: local

Published: 7/13/2022

Updated: 7/13/2022

Risk Information

VPR

Risk Factor: Medium

Score: 6.7

CVSS v2

Risk Factor: Medium

Base Score: 6.4

Temporal Score: 4.7

Vector: AV:N/AC:L/Au:N/C:P/I:N/A:P

Temporal Vector: E:U/RL:OF/RC:C

CVSS Score Source: CVE-2022-2320

CVSS v3

Risk Factor: High

Base Score: 7.8

Temporal Score: 6.8

Vector: CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: E:U/RL:O/RC:C

Vulnerability Information

CPE: p-cpe:/a:slackware:slackware_linux:xorg-server, p-cpe:/a:slackware:slackware_linux:xorg-server-xephyr, p-cpe:/a:slackware:slackware_linux:xorg-server-xnest, p-cpe:/a:slackware:slackware_linux:xorg-server-xvfb, cpe:/o:slackware:slackware_linux, cpe:/o:slackware:slackware_linux:15.0

Required KB Items: Host/local_checks_enabled, Host/Slackware/release, Host/Slackware/packages

Exploit Ease: No known exploits are available

Reference Information

CVE: CVE-2022-2319, CVE-2022-2320