Slackware Linux 14.0 / 14.1 / 14.2 / 15.0 / current wavpack Multiple Vulnerabilities (SSA:2022-191-01)

medium Nessus Plugin ID 162971

Synopsis

The remote Slackware Linux host is missing a security update to wavpack.

Description

The version of wavpack installed on the remote host is prior to 5.5.0. It is, therefore, affected by multiple vulnerabilities as referenced in the SSA:2022-191-01 advisory.

- An out of bounds read was found in Wavpack 5.4.0 in processing *.WAV files. This issue triggered in function WavpackPackSamples of file src/pack_utils.c, tainted variable cnt is too large, that makes pointer sptr read beyond heap bound. (CVE-2021-44269)

Note that Nessus has not tested for these issues but has instead relied only on the application's self-reported version number.

Solution

Upgrade the affected wavpack package.

Plugin Details

Severity: Medium

ID: 162971

File Name: Slackware_SSA_2022-191-01.nasl

Version: 1.2

Type: local

Published: 7/10/2022

Updated: 7/10/2022

Risk Information

VPR

Risk Factor: Low

Score: 3.6

CVSS v2

Risk Factor: Medium

Base Score: 4.3

Temporal Score: 3.2

Vector: CVSS2#AV:N/AC:M/Au:N/C:N/I:N/A:P

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

CVSS Score Source: CVE-2021-44269

CVSS v3

Risk Factor: Medium

Base Score: 5.5

Temporal Score: 4.8

Vector: CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:2.3:o:slackware:slackware_linux:*:*:*:*:*:*:*:*, cpe:2.3:o:slackware:slackware_linux:14.0:*:*:*:*:*:*:*, cpe:2.3:o:slackware:slackware_linux:14.1:*:*:*:*:*:*:*, cpe:2.3:o:slackware:slackware_linux:14.2:*:*:*:*:*:*:*, p-cpe:2.3:a:slackware:slackware_linux:wavpack:*:*:*:*:*:*:*, cpe:2.3:o:slackware:slackware_linux:15.0:*:*:*:*:*:*:*

Required KB Items: Host/local_checks_enabled, Host/Slackware/release, Host/Slackware/packages

Exploit Ease: No known exploits are available

Vulnerability Publication Date: 3/10/2022

Reference Information

CVE: CVE-2021-44269