Slackware Linux 15.0 / current gnupg2 Vulnerability (SSA:2022-188-01)

medium Nessus Plugin ID 162928

Synopsis

The remote Slackware Linux host is missing a security update to gnupg2.

Description

The version of gnupg2 installed on the remote host is prior to 2.2.36. It is, therefore, affected by a vulnerability as referenced in the SSA:2022-188-01 advisory.

- GnuPG through 2.3.6, in unusual situations where an attacker possesses any secret-key information from a victim's keyring and other constraints (e.g., use of GPGME) are met, allows signature forgery via injection into the status line. (CVE-2022-34903)

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.

Solution

Upgrade the affected gnupg2 package.

Plugin Details

Severity: Medium

ID: 162928

File Name: Slackware_SSA_2022-188-01.nasl

Version: 1.3

Type: local

Published: 7/8/2022

Updated: 7/14/2022

Risk Information

VPR

Risk Factor: Medium

Score: 5

CVSS v2

Risk Factor: Medium

Base Score: 5.8

Temporal Score: 4.3

Vector: AV:N/AC:M/Au:N/C:P/I:P/A:N

Temporal Vector: E:U/RL:OF/RC:C

CVSS Score Source: CVE-2022-34903

CVSS v3

Risk Factor: Medium

Base Score: 6.5

Temporal Score: 5.7

Vector: CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:L/A:N

Temporal Vector: E:U/RL:O/RC:C

Vulnerability Information

CPE: p-cpe:/a:slackware:slackware_linux:gnupg2, cpe:/o:slackware:slackware_linux, cpe:/o:slackware:slackware_linux:15.0

Required KB Items: Host/local_checks_enabled, Host/Slackware/release, Host/Slackware/packages

Exploit Ease: No known exploits are available

Vulnerability Publication Date: 7/1/2022

Reference Information

CVE: CVE-2022-34903